Rechnungsvorlagen für QR-Code bereit machen

Erstellt: 06.03.2020, Änderung:
Mehr ansehen

Dieser Artikel ist nur für Kunden in der Schweiz relevant.

Ab dem 30. Juni 2020 können in der Schweiz statt der gewohnten Einzahlungsscheine auch QR-Rechnungen versendet werden.

Die ersten Vertec QR-Rechnungsvorlagen sind bereits mit Vertec 6.2 erschienen. Durch die Verzögerung bei der Einführung der QR-Codes und die nachträgliche Veränderung der Spezifikation ist Vertec aber erst ab Version 6.3.0.17 mit der neusten Spezifikation 2.1 kompatibel.

Bei Vertec Rechnungsvorlagen, welche vor der Vertec Version 6.3.0.17 erstellt wurden, besteht Anpassungsbedarf, damit sie als gültige QR-Rechnungen versendet werden können. Es gibt folgende Szenarien:

Sie verwenden Rechnungen Office- oder Vertec-generiert

Betrifft Word-Rechnungsvorlagen mit der Endung .dotx oder .dotm. Diese Vorlagen müssen auf jeden Fall angepasst werden, wenn Sie sie als QR-Rechnung verwenden wollen. Wie Sie genau vorgehen, ist unter den folgenden Links beschrieben:

Sie verwenden Rechnungen als erweiterte Office-Berichte

Betrifft Word-Rechnungsvorlagen mit der Endung .docx. In diesem Fall müssen Vorlagen vor der Version 6.3.0.17 sowie kundenspezifisch veränderter Berichtscode angepasst werden, um sie als QR-Rechnung verwenden zu können. Wie Sie genau vorgehen, ist unter den folgenden Links beschrieben:

Grundsätzliches

  • Sie müssen eine Vertec Version von mindestens 6.3.0.17 einsetzen, um gültige QR-Rechnungen versenden zu können.
  • Auch nach dem 30.06.2020 können die herkömmlichen Einzahlungsscheine verwendet werden. Im Moment wird von einer Übergangsfrist von rund zwei Jahren ausgegangen.
  • Damit in den Vertec Rechnungsvorlagen die QR-Seite angezeigt wird, muss auf dem Zahlungstyp eine IBAN-Nummer angegeben werden.

Bitte machen Sie von jeder Vorlage ein Backup, bevor Sie sie bearbeiten.

Sie verwenden Rechnungen Office- oder Vertec-generiert

In der Vorlage, die Sie anpassen möchten, besteht bereits eine QR-Seite

Gehe stattdessen zu: In der Vorlage, die Sie anpassen möchten, besteht noch keine QR-Seite

  1. Laden Sie die Beispielvorlage der Rechnung mit QR-Seite in der Sprache Ihrer Vorlage herunter:
  2. Öffnen Sie die Vorlage, die Sie anpassen wollen (Ziel), und die heruntergeladene Beispielvorlage (Quelle).
  3. Markieren Sie in der Quellvorlage die Tabelle mit dem QR-Zahlteil und drücken Sie Ctrl+C für "Kopieren".
  4. Wechseln Sie zur Zielvorlage und markieren Sie ebenfalls die Tabelle mit dem QR-Zahlteil:
  5. Klicken Sie daraufhin mit der rechten Maustaste in die Tabelle und wählen Sie Tabelle löschen:
  6. Drücken Sie dann sofort Ctrl+V für "Einfügen". Wichtig ist, dass Sie zwischen dem Löschen der alten Tabelle und dem Einfügen der neuen Tabelle den Mauszeiger nicht verändern.
  7. Speichern Sie die Vorlage.

In der Vorlage, die Sie anpassen möchten, besteht noch keine QR-Seite

Gehe stattdessen zu: In der Vorlage, die Sie anpassen möchten, besteht bereits eine QR-Seite

  1. Laden Sie die Beispielvorlage der Rechnung mit QR-Seite in der Sprache Ihrer Vorlage herunter:
  2. Öffnen Sie die Vorlage, die Sie anpassen wollen (Ziel), und die heruntergeladene Beispielvorlage (Quelle).
  3. Aktivieren Sie in Ihrem Word unter Datei > Optionen > Erweitert bei Dokumentinhalt anzeigen die Option Textmarken anzeigen:
  4. Das bewirkt, dass Sie die Textmarken sehen im Dokument. Diese sehen so aus:
  5. Öffnen Sie dann die Quell-Vorlage und wechseln Sie auf Ansicht > Gliederung.
  6. Markieren Sie nun die QR-Seite in der Quell-Vorlage, und zwar INKL. Abschnittswechsel (Fortlaufend) bis zur letzten Textmarke, also genau wie in der folgenden Grafik dargestellt, und drücken Sie Ctrl+C für "Kopieren":
  7. Öffnen Sie dann die Ziel-Vorlage ebenfalls in der Gliederungsansicht und setzen Sie den Mauszeiger auf der letzten Seite genau in die Zeile vor der allerletzten Textmarke:
  8. Drücken Sie dann Ctrl+V für Einfügen.
  9. Schliessen Sie die Gliederungsansicht und speichern Sie die Vorlage.

Sie verwenden Rechnungen als erweiterte Office-Berichte (EOB)

In der Vorlage, die Sie anpassen möchten, besteht bereits eine QR-Seite

Gehe stattdessen zu: In der Vorlage, die Sie anpassen möchten, besteht noch keine QR-Seite

  1. Als Beispielvorlage nehmen Sie eine der standardmässig mitgelieferten Rechnungsvorlagen InvoiceWithList.docx, InvoiceWithUserSums.docx oder InvoiceWithPhaseSums.docx ab Vertec 6.3.0.17 (es spielt keine Rolle welche der drei Vorlagen Sie verwenden, der QR-Teil ist bei allen drei gleich).
  2. Öffnen Sie die Vorlage, die Sie anpassen wollen (Ziel), und die Beispielvorlage (Quelle).
  3. Markieren Sie in der Quelle die Tabelle mit dem QR-Zahlteil und drücken Sie Ctrl+C für "Kopieren".
  4. Wechseln Sie zur Ziel-Vorlage und markieren Sie ebenfalls die Tabelle mit dem QR-Zahlteil:
  5. Klicken Sie daraufhin mit der rechten Maustaste in die Tabelle und wählen Sie Tabelle löschen:
  6. Drücken Sie dann sofort Ctrl+V für "Einfügen". Wichtig ist, dass Sie zwischen dem Löschen der alten Tabelle und dem Einfügen der neuen Tabelle den Mauszeiger nicht verändern.
  7. Speichern Sie die Vorlage.

Code anpassen

Falls Sie den ursprünglichen Berichtscode überschrieben oder neuen Berichtscode verwendet haben haben, müssen Sie im Frame Rechnung noch folgende Zeile einfügen:

OclTextField("rech_adresstext", "rechnungsadresse.oclastype(Adresseintrag).adresstext")

In der Vorlage, die Sie anpassen möchten, besteht noch keine QR-Seite

Gehe stattdessen zu: In der Vorlage, die Sie anpassen möchten, besteht bereits eine QR-Seite

  1. Als Beispielvorlage nehmen Sie eine der standardmässig mitgelieferten Rechnungsvorlagen InvoiceWithList.docx, InvoiceWithUserSums.docx oder InvoiceWithPhaseSums.docx ab Vertec 6.3.0.17 (es spielt keine Rolle welche der drei Vorlagen Sie verwenden, der QR-Teil ist bei allen drei gleich).
  2. Öffnen Sie die Vorlage, die Sie anpassen wollen (Ziel), und die Beispielvorlage (Quelle).
  3. Aktivieren Sie in Ihrem Word unter Datei > Optionen > Erweitert bei Dokumentinhalt anzeigen die Option Textmarken anzeigen:
  4. Das bewirkt, dass Sie die Textmarken sehen im Dokument. Diese sehen so aus:
  5. Öffnen Sie dann die Quell-Vorlage und wechseln Sie auf Ansicht > Gliederung.
  6. Markieren Sie nun die QR-Seite in der Quell-Vorlage, und zwar von der Textmarke oberhalb der zweitletzten Tabelle bis zur Textmarke unterhalb der letzten Tabelle, also genau wie in der folgenden Grafik dargestellt, und drücken Sie Ctrl+C für "Kopieren":
  7. Öffnen Sie dann die Ziel-Vorlage ebenfalls in der Gliederungsansicht und setzen Sie den Mauszeiger auf der letzten Seite genau in die Zeile vor der allerletzten Textmarke:
  8. Drücken Sie dann Ctrl+V für Einfügen.
  9. Schliessen Sie die Gliederungsansicht und speichern Sie die Vorlage.

Code anpassen

Falls Sie den ursprünglichen Berichtscode überschrieben oder neuen Berichtscode verwendet haben haben, müssen Sie im Frame Rechnung folgenden Block (bzw. die Zeilen, die davon noch nicht vorhanden sind) einfügen:

# QR
OclBooleanField("has_iban", "iban <> ''"),
OclBooleanField("has_QRCode_error", "qrcodeerror <> ''"),
OclTextField("iban"),
OclImageField("qrcode"),
OclTextField("qrcodeerror"),
OclBooleanField("QRCodeIsValid", "qrcodeerror = ''"),
OclTextField("rech_adresstext", "rechnungsadresse.oclastype(Adresseintrag).adresstext")