Der Bericht-Designer

Der Bericht-Designer, auch Report Builder genannt, wird in einem eigenen Fenster dargestellt. Am besten wird dieses auf Vollbildgrösse gestellt.

Aufbau

Der Bericht-Designer ist wie folgt aufgebaut:

Im oberen Teil befindet sich ein Menü:

Menu

Danach folgen Reiter, um zwischen den drei Grundfunktionen des Designers zu wechseln:

Reiter

Anschliessend folgen Werkzeugleisten. Die Ansicht hier kann variieren, da der Aufbau der Leisten konfiguriert werden kann (Im Menü Ansicht / Werkzeugleisten):

Werzeuge

Und schliesslich folgt der eigentliche Editor:

Editor

Grundfunktionen

Daten:

Hier wird festgelegt, welche Datenquellen dem Report zur Verfügung stehen, wie diese zueinander in Zusammenhang stehen und welche Datenfelder verwendet werden können. Hier kann auch die Datenanbindung vorgenommen werden.

Entwurf:

Ist wie oben dargestellt der eigentliche Editor. Hier kann das Layout des Reports bestimmt werden. Dies basiert auf der Platzierung von Elementen (Elemente können Texte, Datenfelder, Linien usw. sein). Zudem wird hier der Berichtaufbau definiert.

Vorschau:

Mit dieser Funktion kann jederzeit geprüft werden, wie der Report effektiv dargestellt wird. Dies erfolgt unter Verwendung der Daten, die bei der Registrierung als Testdaten definiert wurden (wurde z.B. eine bestimmte Vertec-Rechnung per Drag n’Drop in dieses Feld platziert, erfolgt die Vorschau immer mit den Daten dieser Rechnung).

Einen Bericht laden

Wechseln Sie in die Entwurfsansicht. Über das Menü "File > Aus Datei importieren..." wählen Sie den gewünschten Bericht aus (Datei mit der Endung .rtm).

Einen Bericht laden

Eine Vielzahl von vordefinierten Berichten finden Sie im Vertec im Ordner Einstellungen > Berichtsvorlagen. Um einen solchen Bericht zu verwenden, können Sie ihn auf aktiv schalten.

Seite einrichten

Über das Menü Datei > Seite einrichten lassen sich der Drucker sowie der Druckerschacht für den Report einstellen. Diese Einstellung gilt für den gesamten Report, also auch für die Unterberichte.

Report Builder Professional Dokumentation und Tutorials

Infos und Links zu Dokumentation des Report Builders Professional von Digital Metaphors. In Vertec ist die Version 7.02 des Report Builders Professional eingebaut. Die Scriptsprache RAP wird von Vertec nicht unterstützt.

Dokumentation Report Builder als PDF

Relevant sind:


03.12.2003 | 26.04.2010